Warning: Parameter 2 to wp_hide_post_Public::query_posts_join() expected to be a reference, value given in /home/oldalgazdahu/oldalgazda.hu/wp-includes/class-wp-hook.php on line 287
XOOPS CMS | Oldalgazda
Warning: Parameter 2 to wp_hide_post_Public::query_posts_join() expected to be a reference, value given in /home/oldalgazdahu/oldalgazda.hu/wp-includes/class-wp-hook.php on line 287

Warning: Parameter 2 to wp_hide_post_Public::query_posts_join() expected to be a reference, value given in /home/oldalgazdahu/oldalgazda.hu/wp-includes/class-wp-hook.php on line 287

XOOPS CMS

február 15, 2011

mohalaci2011-02-15 20:06:26

Üdv!

van egy ilyen CMS rendszer aminek a neve: XOOPS

Sajnos a hivatalos magyar oldala meghalt, és nincsen a legujabb verzióhoz magyar fordítás, ezért arra gondoltam, hogy magam fogom lefordítani.

Mivel nem tudom, hogy hogyan tudnék új nyelvet belerakni, ezért az eredeti angol nylevet irnám át magyarra, de az ékezetes karaktereket nem támogatja:S kérdöjeleket ir helyette..

pl: Ir�nyit� pult

az angol nyelvi fájlokban azt látom, hogy UTF-8 karakterkodolással van irva, de az adatbázisban latin2_general_ci kodolás van beállitva

mit tegyek, hogy jo legyen?

OldalGazda2011-02-16 17:11:21

Szia, amikor ilyet látsz, hogy kérdőjelek jelennek meg egy ékezetes szövegben, az mindig azt jelenti, hogy valamilyen 8-bites kódolású (Central-European, Western-European, Latin-2, Latin-2) szöveget próbálsz meg nagy erőkkel UTF-8 ban megjeleníteni.

Javaslom, hogy nyisd meg Latin-2 vagy más néven ISO-8859-2 karakterkódolással a magyar fordítás szöveges fájljait és úgy próbáld meg szerkeszteni. Ahogy elnézem, a fordítások sima php fájlokban vannak. Láttam az aljukban ilyet:

//%%%%%        LANGUAGE SPECIFIC SETTINGS   %%%%%
define('_CHARSET', 'ISO-8859-2');
define('_LANGCODE', 'hu');

Lehet, hogy el lehetne játszani ezzel is, hogy átállítod UTF-8-ra, de szerintem mielőtt ilyet csinálsz, kérdezz rá valamilyen Xoops fórumon, hogy mit szólnának ehhez.

mohalaci2011-02-16 20:07:09

Értem, ezt melyik fájlban láttad? mert én ilyen sort még nem találtam...:D

nem értem, hogy az iso kodolás miért nem fogadja el az ékezetes karaktereket, mert van egy smf forumom ami iso karakterkodolást használ és megjelenit mindent...

Köszönöm a tippet!

mohalaci2011-02-16 20:16:56

jah már látom hol találtad 😀 csak én mindig jegyzettömben néztem a php fájlt és az nem tagolja szét igy elkerülte a figyelmem...:S

UTF-8 volt a karakterkodolás és átirtam ISO-8859-2 kodolásra és jo lett az ékezetes betü 😉

Köszi a segítséget!